Apache Tomcat < 6.0.16 Information Disclosure

Medium Nessus Network Monitor Plugin ID 4368

Synopsis

The remote web server can be manipulated into disclosing confidential data.

Description

The remote host is running a version of Tomcat server lower than 6.0.16. This version of Tomcat is vulnerable to a flaw in the way that it handles exceptions. According to the vendor, if an exception occurs during the processing of parameters, the parameters may be used in future requests to disclose potentially confidential data.

Solution

Upgrade or patch according to vendor recommendations.

See Also

http://tomcat.apache.org

Plugin Details

Severity: Medium

ID: 4368

File Name: 4368.prm

Family: Web Servers

Published: 2008/02/08

Modified: 2016/11/23

Dependencies: 3057

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Reference Information

CVE: CVE-2008-0002, CVE-2007-5333

BID: 27706, 27703