Samba < 3.0.28 'send_mailslot' Function Buffer Overflow

Critical Nessus Network Monitor Plugin ID 4311

Synopsis

The remote Samba server may be affected by a buffer overflow vulnerability.

Description

According to its banner, the version of the Samba server on the remote host is reportedly affected by a boundary error in 'nmbd' within the 'send_mailslot' function. Provided the 'domain logons' option is enabled in 'smb.conf', an attacker can leverage this issue to produce a stack-based buffer overflow using a 'SAMLOGON' domain logon packet in which the username string is placed at an odd offset and is followed by a long 'GETDC' string. Note that PVS has not verified whether 'domain logons' are enabled on the remote host.

Solution

Upgrade to version 3.0.28 or higher.

See Also

http://www.securityfocus.com/archive/1/484763/30/0/threaded

http://us3.samba.org/samba/security/CVE-2007-6015.html

Plugin Details

Severity: Critical

ID: 4311

File Name: 4311.prm

Family: Samba

Published: 2007/12/10

Modified: 2016/01/19

Dependencies: 8740

Nessus ID: 29252

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2007/12/13

Vulnerability Publication Date: 2007/12/13

Reference Information

CVE: CVE-2007-6015

BID: 26791