PHP 5.x < 5.2.4 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 4202
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote host is vulnerable to multiple attack vectors.


The remote host is running a version of PHP 5.x prior to 5.2.4. This version of PHP is vulnerable to at least 120 distinct security flaws impacting confidentiality, integrity and availability.


Upgrade to version 5.2.4 or higher.

See Also

Plugin Details

Severity: High

ID: 4202

Family: Web Servers

Published: 8/31/2007

Updated: 3/6/2019

Dependencies: 8682

Risk Information


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Risk Factor: High

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Patch Publication Date: 7/16/2007

Vulnerability Publication Date: 7/16/2007

Reference Information

CVE: CVE-2007-2872, CVE-2007-3378, CVE-2007-3806

BID: 25498