Apache Tomcat < 5.5.25 / 6.0.x < 6.0.14 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 4167

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running the Apache Tomcat server. This version of Tomcat is vulnerable to two distinct classes of flaws. First, the application is vulnerable to a Cross-Site Scripting flaw in the 'aliases' parameter of the '/host-manager/html/add' script. Second, the application is vulnerable to a number of flaws that would reveal sensitive information. An attacker exploiting these flaws would be able to either execute code within client browsers or gain information that would be useful for further attacks against Tomcat.

Solution

Upgrade to version 5.5.25, 6.0.14 or higher.

See Also

http://tomcat.apache.org

Plugin Details

Severity: Medium

ID: 4167

Family: Web Servers

Published: 8/14/2007

Updated: 3/6/2019

Dependencies: 8926, 8927

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 4.8

Temporal Score: 4.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2007-3382, CVE-2007-3385, CVE-2007-3386

BID: 25316, 25314