Curl < 7.16.4 Expired Certificate Access Restriction Bypass

Low Nessus Network Monitor Plugin ID 4137

Synopsis

The remote host may allow access to unauthorized websites via an expired certificate.

Description

The remote host is running Curl, a download client for various protocols. This version of Curl is vulnerable to an authentication flaw in the GnuTLS certificate verification routine. An attacker exploiting this flaw would be able to use an expired certificate.

Solution

Upgrade to version 7.16.4 or higher.

See Also

http://curl.haxx.se

Plugin Details

Severity: Low

ID: 4137

Family: Web Clients

Published: 2007/07/17

Modified: 2016/12/06

Dependencies: 1735, 8314

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 2.9

Temporal Score: 2.4

Vector: CVSS2#AV:A/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 3

Temporal Score: 2.8

Vector: CVSS3#AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:haxx:curl

Reference Information

CVE: CVE-2007-3564

BID: 24938