Mozilla Firefox 1.5.x < 1.5.0.12 / 2.x < 2.0.0.4 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 4071

Synopsis

The remote host has a web browser installed that is vulnerable to multiple attack vectors.

Description

Versions of Mozilla Firefox 1.5.x prior to 1.5.0.12, or 2.x prior to 2.0.0.4 are affected by various security issues, one of which may lead to execution of arbitrary code on the affected host subject to the user's privileges.

Solution

Upgrade to version 1.5.0.12 / 2.0.0.4 or higher.

See Also

https://bugzilla.mozilla.org/show_bug.cgi?id=370555

http://www.mozilla.org/security/announce/2007/mfsa2007-12.html

http://www.mozilla.org/security/announce/2007/mfsa2007-13.html

http://www.mozilla.org/security/announce/2007/mfsa2007-14.html

http://www.mozilla.org/security/announce/2007/mfsa2007-16.html

http://www.mozilla.org/security/announce/2007/mfsa2007-17.html

http://www.mozilla.org

Plugin Details

Severity: High

ID: 4071

Family: Web Clients

Published: 2007/05/31

Updated: 2019/03/06

Dependencies: 9131

Nessus ID: 25349

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Reference Information

CVE: CVE-2007-2868, CVE-2007-2867, CVE-2007-2869, CVE-2007-2870, CVE-2007-2871, CVE-2007-1362

BID: 22879, 24242