Opera < 9.21 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 3996

Synopsis

The remote host contains a web browser that is prone to a buffer overflow attack.

Description

The version of Opera installed on the remote host reportedly contains a buffer overflow vulnerability that can be triggered by a malicious Torrent file. Successful exploitation requires that a user on the affected host right-click on the torrent entry in the transfer manager rather than simply click on a torrent link and may allow a remote attacker to execute arbitrary code subject to the privileges of the user.

Solution

Upgrade to version 9.21 or higher.

See Also

http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=535

http://archives.neohapsis.com/archives/bugtraq/2007-05/0357.html

http://www.opera.com/support/search/view/860

Plugin Details

Severity: Medium

ID: 3996

Family: Web Clients

Published: 2007/05/21

Modified: 2018/09/16

Dependencies: 1735, 8314

Nessus ID: 25290

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.4

Temporal Score: 4

Vector: CVSS2#AV:A/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5

Temporal Score: 4.4

Vector: CVSS3#AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:opera:opera_browser

Reference Information

CVE: CVE-2007-2809, CVE-2007-2274

BID: 24080