Oracle MySQL < 5.0.40 IF Query NULL Dereference DoS

Low Nessus Network Monitor Plugin ID 3985

Synopsis

The remote database server is prone to a denial of service attack.

Description

The version of MySQL installed on the remote host is reportedly affected by a denial of service vulnerability that may be triggered with a specially crafted IF query. An attacker who can execute arbitrary SELECT statements may be able to leverage this issue to crash the affected service.

Solution

Upgrade to version 5.0.40 or higher.

See Also

http://dev.mysql.com/doc/refman/5.0/en/releasenotes-cs-5-0-41.html

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-18.html

http://dev.mysql.com/doc/refman/5.0/en/releasenotes-es-5-0-40.html

http://bugs.mysql.com/bug.php?id=27513

Plugin Details

Severity: Low

ID: 3985

Family: Database

Published: 2007/05/10

Modified: 2018/09/16

Dependencies: 8914

Nessus ID: 25198

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.3

Temporal Score: 2.7

Vector: CVSS2#AV:A/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 4.2

Temporal Score: 3.9

Vector: CVSS3#AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Reference Information

CVE: CVE-2007-2583

BID: 23911