PostgreSQL SECURITY DEFINER Functions Local Privilege Escalation

Medium Nessus Network Monitor Plugin ID 3973

Synopsis

The remote host is vulnerable to a local 'privilege escalation' flaw.

Description

The remote host is running PostgreSQL, an open source relational database. This version is vulnerable to a local 'privilege escalation' flaw. By accessing temporary objects, a local user can escalate privileges. Successful exploitation would allow the local user to gain access elevated access to PostgreSQL data.

Solution

Upgrade to version 7.3.19, 7.4.17, 8.0.13, 8.1.9, 8.2.4 or higher.

See Also

http://www.postgresql.org

Plugin Details

Severity: Medium

ID: 3973

Family: Database

Published: 2007/04/24

Modified: 2016/02/05

Dependencies: 8703, 8704

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:L/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.2

Temporal Score: 4.5

Vector: CVSS3#AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Reference Information

CVE: CVE-2007-2138

BID: 23618