PostgreSQL Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 3901

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running PostgreSQL, an open source relational database. This version is vulnerable to multiple flaws where an attacker with a valid user account can cause the service to stop or potentially disclose confidential information. Successful exploitation would result in the system being unavailable to legitimate users or the leakage of confidential data.

Solution

Upgrade to version 7.3.16, 7.4.16, 8.0.11, 8.1.7, 8.2.2 or higher.

See Also

http://www.postgresql.org

Plugin Details

Severity: Medium

ID: 3901

Family: Database

Published: 2007/02/06

Modified: 2016/01/21

Dependencies: 8703, 8704

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 5.9

Vector: CVSS3#AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Reference Information

CVE: CVE-2007-0555, CVE-2007-0556

BID: 22387