Phorum < 5.1.19 register.php XSS

Medium Nessus Network Monitor Plugin ID 3898

Synopsis

The remote host is vulnerable to a Cross-Site Scripting (XSS) attack.

Description

The remote version of Phorum contains a script called 'register.php' that is vulnerable to a cross-site scripting attack via the 'username' parameter. An attacker may exploit this problem to steal the authentication credentials of third party users.

Solution

Upgrade to version 5.1.19 or higher.

See Also

http://www.phorum.org

Plugin Details

Severity: Medium

ID: 3898

Family: Web Servers

Published: 2007/01/29

Modified: 2016/02/05

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.4

Temporal Score: 5.1

Vector: CVSS2#AV:A/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

CVSSv3

Base Score: 5

Temporal Score: 4.8

Vector: CVSS3#AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:U/RC:X

Vulnerability Information

CPE: cpe:/a:phorum:phorum

Reference Information

CVE: CVE-2007-0769

BID: 22297