Winamp < 5.31 Multiple Heap Overflows

Low Nessus Network Monitor Plugin ID 3800

Synopsis

The remote host is vulnerable to a heap overflow.

Description

The remote host is running Winamp, a multi-media software application. This version of Winamp is vulnerable to multiple heap overflows. Specifically, the application fails to handle buffers when handling 'ultravox-max' and 'Lyrics3' tags. An attacker exploiting this flaw would need to be able to convince a user into perusing a malicious media server. Successful exploitation would give the attacker the ability to execute code with the privileges of the user running Winamp.

Solution

Upgrade to version 5.31 or higher.

See Also

http://www.winamp.com

Plugin Details

Severity: Low

ID: 3800

Family: Generic

Published: 2006/10/25

Modified: 2018/07/11

Dependencies: 1735, 8314

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 2.9

Temporal Score: 2.4

Vector: CVSS2#AV:A/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 3

Temporal Score: 2.8

Vector: CVSS3#AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:nullsoft:winamp

Reference Information

CVE: CVE-2006-5567

BID: 20744, 23568