CommuniGate Pro < 5.1c2 POP3 Overflow

High Nessus Network Monitor Plugin ID 3679

Synopsis

The remote mail server is prone to multiple attack vectors.

Description

According to its banner, the version of CommuniGate Pro running on the remote host will crash when certain mail clients try to open an empty mailbox. Remote code execution may even be possible.

Solution

Upgrade to version 5.1c2 or higher.

See Also

http://www.securityfocus.com/archive/1/423364

http://lists.grok.org.uk/pipermail/full-disclosure/2006-January/041863.html

http://www.nessus.org/u?10470ceb

http://www.stalker.com/CommuniGatePro/History.html

Plugin Details

Severity: High

ID: 3679

File Name: 3679.prm

Family: Web Servers

Published: 2006/07/05

Modified: 2016/01/21

Dependencies: 1442

Nessus ID: 21917, 20827

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:U/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:U/RC:C

Reference Information

CVE: CVE-2006-3477, CVE-2006-0468

BID: 18770, 16407

OSVDB: 22787, 22788, 26954