PostgreSQL SQL Injection

High Nessus Network Monitor Plugin ID 3632

Synopsis

The remote host is vulnerable to a SQL Injection attack.

Description

The remote host is running PostgreSQL, an open source relational database. This version is vulnerable to a SQL Injection flaw when passed properly formatted SQL queries coupled with invalidly-encoded multibyte data. An attacker exploiting this flaw would need to be able to send queries to the PostgreSQL server. As such, this exploit typically requires authentication. Successful exploitation would result in the attacker executing arbitrary SQL commands on the database server.

Solution

Upgrade to version 7.3.15, 7.4.13, 8.0.8, 8.1.4, or higher.

See Also

http://www.postgresql.org

Plugin Details

Severity: High

ID: 3632

File Name: 3632.prm

Family: Database

Published: 2006/05/25

Modified: 2016/01/15

Dependencies: 8703, 8704

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Reference Information

CVE: CVE-2006-2313, CVE-2006-2314

BID: 18092