Mozilla Firefox 1.5.x < 1.5.0.3 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 3531

Synopsis

The remote host has a web browser installed that is vulnerable to multiple attack vectors.

Description

Versions of Mozilla Firefox 1.5.x prior to 1.5.0.3 are affected by various security issues, several of which are critical as they can be easily exploited to execute arbitrary shell code on the remote host. The version of Firefox is vulnerable to multiple denial of service attacks, overflows, information disclosure, privilege escalation, and other issues. An attacker exploiting these flaws would need to be able to convince a user to browse to a malicious URI.

Solution

Upgrade to version 1.5.0.3 or higher.

See Also

http://www.mozilla.org

Plugin Details

Severity: Medium

ID: 3531

File Name: 3531.prm

Family: Web Clients

Published: 2004/08/18

Modified: 2016/03/12

Dependencies: 9131

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.4

Temporal Score: 4.2

Vector: CVSS2#AV:A/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSSv3

Base Score: 5

Temporal Score: 4.5

Vector: CVSS3#AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Reference Information

CVE: CVE-2006-1993

BID: 17671

OSVDB: 24967