Mozilla Firefox < 1.0.8 / 1.5.x < 1.5.0.2 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 3512

Synopsis

The remote host has a web browser installed that is vulnerable to multiple attack vectors.

Description

Versions of Mozilla Firefox prior to 1.5.0.2 or 1.0.8 are affected by various security issues, several of which are critical as they can be easily exploited to execute arbitrary shell code on the remote host. The version of Firefox is vulnerable to multiple denial of service attacks, overflows, information disclosure, privilege escalation, and other issues. An attacker exploiting these flaws would need to be able to convince a Firefox user to browse to a malicious URI.

Solution

Upgrade to version 1.5.0.2, 1.0.8 or higher.

See Also

http://www.mozilla.org

Plugin Details

Severity: Medium

ID: 3512

Family: Web Clients

Published: 2004/08/18

Updated: 2019/03/06

Dependencies: 9131

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.4

Temporal Score: 4.5

Vector: CVSS2#AV:A/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 5

Temporal Score: 4.7

Vector: CVSS:3.0/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Exploitable With

Metasploit (Firefox location.QueryInterface() Code Execution)

Reference Information

CVE: CVE-2006-0296, CVE-2005-4134, CVE-2006-0294, CVE-2006-0295, CVE-2006-0297, CVE-2006-0298, CVE-2006-0299, CVE-2006-0748, CVE-2006-0749, CVE-2006-1045, CVE-2006-1731, CVE-2006-1732, CVE-2006-1733, CVE-2006-1734, CVE-2006-1735, CVE-2006-1736, CVE-2006-1737, CVE-2006-1738, CVE-2006-1739, CVE-2006-1740, CVE-2006-1790, CVE-2006-1742, CVE-2006-1724, CVE-2006-1529, CVE-2006-1530, CVE-2006-0292, CVE-2006-0293, CVE-2006-1531, CVE-2006-1723, CVE-2006-1725, CVE-2006-1726, CVE-2006-1727, CVE-2006-1728, CVE-2006-1729, CVE-2006-1730

BID: 17499, 17516, 16476