Ipswitch Multiple Products < 2006.03 IMAP FETCH Command Overflow

Medium Nessus Network Monitor Plugin ID 3473

Synopsis

The remote IMAP server is affected by a buffer overflow vulnerability.

Description

The remote host is running Ipswitch Collaboration Suite / IMail Secure Server / IMail Server, commercial messaging and collaboration suites for Windows. According to its banner, the version of Ipswitch Collaboration Suite / IMail Secure Server / IMail Server installed on the remote host has a buffer overflow issue in its IMAP server component. Using a specially-crafted FETCH command with excessive data, an authenticated attacker can crash the IMAP server on the affected host, thereby denying service to legitimate users and possibly execute arbitrary code as LOCAL SYSTEM.

Solution

Upgrade to version 2006.03 or higher.

See Also

http://www.zerodayinitiative.com/advisories/ZDI-06-003.html

http://www.ipswitch.com/support/ics/updates/ics200603prem.asp

http://www.ipswitch.com/support/ics/updates/ics200603stan.asp

http://www.ipswitch.com/support/imail/releases/imsec200603.asp

http://www.ipswitch.com/support/imail/releases/im200603.asp

Plugin Details

Severity: Medium

ID: 3473

Family: SMTP Servers

Published: 2006/03/13

Modified: 2016/02/05

Dependencies: 2004, 2005

Nessus ID: 21051

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.2

Temporal Score: 3.8

Vector: CVSS2#AV:A/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS3#AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Reference Information

CVE: CVE-2005-3526

BID: 17063