Acme thttpd < 2.26 htpasswd Utility Overflow

Medium Nessus Network Monitor Plugin ID 3463

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host is running a vulnerable version of Acme thttpd. It is reported that versions prior to 2.26 contain a flaw within the 'htpasswd' utility. The htpasswd binary does not correctly verify the amount of data that it is parsing. Given this, a long argument passed to the htpasswd utility may cause a buffer overflow. An attacker exploiting this flaw would need to be able to find a system that calls htpasswd via a dynamic page (such as a CGI script). In addition, the application is vulnerable to a flaw in the way that it creates local temporary files. A local attacker exploiting this flaw would be able to modify or delete files with the privileges of the thttpd server process.

Solution

Upgrade to version 2.26 or higher.

See Also

http://www.acme.com/software/thttpd

Plugin Details

Severity: Medium

ID: 3463

File Name: 3463.prm

Family: Web Servers

Published: 2006/03/06

Modified: 2016/11/23

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.6

Temporal Score: 4

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 5.9

Temporal Score: 5.6

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:acme:thttpd

Reference Information

CVE: CVE-2006-4248, CVE-2006-1078, CVE-2006-1079

BID: 20891, 16972