Apache mod_python < 3.2.8 Remote Command Execution

High Nessus Network Monitor Plugin ID 3453

Synopsis

The remote host is vulnerable to an flaw that allows attackers to execute arbitrary commands.

Description

The remote Apache server is running a version of mod_python that is equal to 3.2.7. It is reported that a flaw was introduced with version 3.2.7. Specifically, if 'FileSession' has been enabled, a remote attacker can send a specially formatted session cookie that will, upon being parsed, force mod_python into executing arbitrary code. The exact details of the flaw are unknown.

Solution

Upgrade to version 3.2.8, 3.3.1 or higher.

See Also

http://www.modpython.org/fs_sec_warn.html

Plugin Details

Severity: High

ID: 3453

Family: Web Servers

Published: 2006/03/02

Modified: 2016/01/22

Dependencies: 3057

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.4

Temporal Score: 7.3

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Reference Information

CVE: CVE-2006-1095

BID: 16916