Mozilla Firefox < 1.5.0.1 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 3405
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host has a web browser installed that is vulnerable to multiple attack vectors.

Description

Versions of Mozilla Firefox prior to 1.5.0.1 are reported to be prone to a cross-domain scripting flaw. An attacker exploiting this flaw would need to be able to convince a user to browse to a malicious URI. Successful exploitation would result in the attacker executing malicious script code within the Firefox browser. In addition, the remote browser is vulnerable to a memory corruption and authentication bypass flaw. An attacker exploiting these flaws would be able to execute arbitrary code on the remote browser or gain access to critical functions.

Solution

Upgrade to version 1.5.0.1 or higher.

See Also

http://www.mozilla.org

Plugin Details

Severity: Medium

ID: 3405

Family: Web Clients

Published: 2/2/2006

Updated: 3/6/2019

Dependencies: 9131

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.5

Vector: CVSS2#AV:A/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.7

Vector: CVSS:3.0/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:*

Exploitable With

Metasploit (Firefox location.QueryInterface() Code Execution)

Reference Information

CVE: CVE-2005-4134, CVE-2006-0292, CVE-2006-0296, CVE-2006-0295, CVE-2006-0294, CVE-2006-0297, CVE-2006-0298, CVE-2006-0299, CVE-2006-0293, CVE-2006-0496

BID: 16476, 16427, 16741