PHP 5.1.x < 5.1.2 mysqli Error Message Format String

High Nessus Network Monitor Plugin ID 3368


The remote host is vulnerable to a remote 'format string' flaw.


The remote host is running a version of PHP that is older than 5.1.2. Versions 5.1.0 and 5.1.1 are potentially vulnerable to a remote format string vulnerabilty. Specifically, if PHP is configured to log MySQL errors, then an attacker may be able to trigger a condition wherein arbitrary commands or code are executed.


Upgrade to version 5.1.2 or higher.

See Also

Plugin Details

Severity: High

ID: 3368

File Name: 3368.prm

Family: Web Servers

Published: 2006/01/12

Modified: 2016/11/23

Dependencies: 8682

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 8.1

Temporal Score: 7.1


Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2006/01/12

Vulnerability Publication Date: 2006/01/12

Reference Information

CVE: CVE-2006-0200

BID: 16219