HylaFAX < 4.2.4 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 3345

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running HylaFAX, a fax transmission software. It is reported that HylaFAX is prone to a number of flaws that would allow a remote attacker to execute arbitrary commands with the permission of the process running HylaFAX. In addition, the application is vulnerable to a flaw that would allow remote attackers to bypass authentication, giving them administrative access without the proper credentials. An attacker exploiting either of these flaws will be able to gain control of the remote HylaFAX server.

Solution

Upgrade to version 4.2.4 or higher.

See Also

http://bugs.hylafax.org/bugzilla/show_bug.cgi?id=682

http://www.hylafax.org/content/HylaFAX_4.2.4_release

Plugin Details

Severity: High

ID: 3345

File Name: 3345.prm

Family: Generic

Published: 2006/01/06

Modified: 2016/11/23

Nessus ID: 20387

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Reference Information

CVE: CVE-2005-3539, CVE-2005-3538

BID: 16150, 16151