Lynx < 2.8.6 dev15 Arbitary Code Execution

Medium Nessus Network Monitor Plugin ID 3287

Synopsis

The remote host is vulnerable to an arbitrary 'command insertion' flaw.

Description

The remote host is using Lynx as a web browser. This version of Lynx is vulnerable to a flaw where an attacker, convincing a Lynx user to browse a malicious URI, can execute arbitrary code on the remote system.

Solution

Upgrade to version 2.8.6 dev15 or higher.

See Also

http://lynx.browser.org

Plugin Details

Severity: Medium

ID: 3287

Family: Web Clients

Published: 2005/11/13

Modified: 2016/01/19

Dependencies: 1735, 8314

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:lynx:lynx

Reference Information

CVE: CVE-2005-2929

BID: 15395