PHP 4.x < 4.4.0 / 5.x < 5.0.6 GLOBAL Variable Overwrite

Medium Nessus Network Monitor Plugin ID 3273

Synopsis

The remote host may give an attacker information useful for future attacks.

Description

The remote host is running a version of PHP that is older than 4.4.0 or 5.0.6. This version has a flaw where remote attackers can reenable the 'register_globals' parameter. In addition, a remote attacker may be able to overwrite the 'GLOBAL' variable. This may lead to another more serious exploitation.

Solution

Upgrade to version 5.0.6 or higher.

See Also

http://www.php.net/release_4_4_1.php

http://php.net/ChangeLog-4.php

http://php.net/ChangeLog-5.php

Plugin Details

Severity: Medium

ID: 3273

File Name: 3273.prm

Family: Web Servers

Published: 2005/10/31

Modified: 2016/02/05

Dependencies: 8728, 8682

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:A/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5

Temporal Score: 4.3

Vector: CVSS3#AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2005/10/30

Vulnerability Publication Date: 2005/10/30

Reference Information

CVE: CVE-2005-3390, CVE-2005-3392, CVE-2005-3391

BID: 15248, 15249, 15250