PHP < 5.0.5 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 3262

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running a version of PHP that is older than 5.0.5. This version has a number of bugs that allow attackers to execute or retrieve arbitrary files outside of the web root directory. An attacker exploiting these flaws would only need to send a malformed HTTP request to the vulnerable system. Successful exploitation would result in the loss of confidential data or a breach of system integrity.

Solution

Upgrade to version 5.0.5 or higher.

See Also

http://php.net/ChangeLog-4.php

http://php.net/ChangeLog-5.php

Plugin Details

Severity: High

ID: 3262

File Name: 3262.prm

Family: Web Servers

Published: 2005/04/01

Modified: 2016/01/15

Dependencies: 8728, 8682

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2005/03/25

Vulnerability Publication Date: 2005/03/31

Reference Information

BID: 15119