XMail < 1.22.0 Multiple Overflows

High Nessus Network Monitor Plugin ID 3257

Synopsis

The remote host is vulnerable to multiple buffer overflow attacks.

Description

The remote XMail server is vulnerable to multiple remote and local buffer overflows. Successful exploitation would lead to the attacker executing arbitrary code.

Solution

Upgrade to version 1.22.0 or higher.

Plugin Details

Severity: High

ID: 3257

Family: POP Server

Published: 2005/10/14

Updated: 2019/03/06

Dependencies: 3035

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:davide_libenzi:xmail

Reference Information

CVE: CVE-2005-2943

BID: 15103