CVS < 1.12.13 Local 'tmp' File Permission Vulnerability

Low Nessus Network Monitor Plugin ID 3181

Synopsis

The remote host is vulnerable to a local flaw in the way that it creates temporary files.

Description

The remote host is running a CVS server that, according to its version number, is vulnerable to a flaw in the way that it creates and protects temporary files. A local user exploiting this flaw may be able to write arbitrary information into critical CVS files.

Solution

Upgrade to version 1.12.13 or higher.

Plugin Details

Severity: Low

ID: 3181

File Name: 3181.prm

Family: Generic

Published: 2005/08/24

Modified: 2016/01/30

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.6

Temporal Score: 3.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:ND

CVSSv3

Base Score: 5.1

Temporal Score: 4.9

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:H/RL:O/RC:X

Reference Information

BID: 14648