BusinessMail SMTP < 4.7 Multiple Command Remote Overflows

Medium Nessus Network Monitor Plugin ID 3155

Synopsis

The remote host is vulnerable to multiple buffer overflows.

Description

The remote host is running a version of BusinessMail that fails to sanitize user-supplied SMTP input. An attacker exploiting this flaw would be able to potentially execute malicious code on the remote server.

Solution

Upgrade to version 4.7 or higher.

Plugin Details

Severity: Medium

ID: 3155

Family: SMTP Servers

Published: 2005/08/02

Modified: 2018/09/16

Dependencies: 2004, 2005

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.2

Temporal Score: 3.8

Vector: CVSS2#AV:A/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS3#AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:netcplus:businessmail

Reference Information

CVE: CVE-2005-2472

BID: 14434