Monkey HTTP Daemon < 0.9.1 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 2835

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The version of the Monkey HTTP Server installed on the remote host suffers from the following flaws:

- A format string vulnerability. A remote attacker may be able to execute arbitrary code with the permissions of the user running monkeyd by sending a specially-crafted request.

- A denial of service vulnerability. Repeated requests for a zero-byte length file, if one exists, could cause the web server to crash.

Solution

Upgrade to version 0.9.1 or higher.

See Also

http://bugs.gentoo.org/show_bug.cgi?id=87916

Plugin Details

Severity: High

ID: 2835

Family: Web Servers

Published: 2005/04/18

Modified: 2016/01/15

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Reference Information

CVE: CVE-2005-1123

BID: 13187, 13188