Pavuk < 0.9.32 Multiple Unspecified Remote Buffer Overflows

High Nessus Network Monitor Plugin ID 2794

Synopsis

The remote host is vulnerable to an arbitrary 'command insertion' flaw.

Description

The remote host is using a version of Pavuk, a web spider, that is vulnerable to multiple unspecified buffer overflows. An attacker can construct a malicious website that is designed to trigger the vulnerability and run arbitrary code on the client machine.

Solution

Upgrade to Pavuk 0.9.32 or higher.

Plugin Details

Severity: High

ID: 2794

File Name: 2794.prm

Family: Web Clients

Published: 2005/04/06

Modified: 2016/02/05

Dependencies: 1735, 8314

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.6

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Reference Information

BID: 13005