Bakbone NetVault Multiple Vulnerabilities

Critical Nessus Network Monitor Plugin ID 2784

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host is running Bakbone NetVault, an enterprise backup/restore application. This version of NetVault is vulnerable to a remote heap overflow as well as a local content-parsing overflow. An attacker exploiting the first flaw would need to be able to connect to the application on port 20031. A successful exploit would result in arbitrary code being executed by the SYSTEM process. An attacker exploiting the second flaw would need local read/write access to the Netvault configuration files. A successful attack would lead to arbitrary code being executed.

Solution

No solution is known at this time.

See Also

http://www.hat-squad.com/en/000164.html

http://archives.neohapsis.com/archives/bugtraq/2005-05/0133.html

http://archives.neohapsis.com/archives/bugtraq/2005-05/0167.html

http://www.bakbone.com/docs/NetVault_Release_Notes_(712).pdf

http://www.bakbone.com/docs/NetVault_Release_Notes_(731).pdf

Plugin Details

Severity: Critical

ID: 2784

File Name: 2784.prm

Family: Generic

Published: 2005/04/04

Modified: 2016/01/19

Nessus ID: 18257

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Exploitable With

Metasploit (BakBone NetVault Remote Heap Overflow)

Reference Information

CVE: CVE-2005-1009, CVE-2005-1547

BID: 13594, 13618, 12967, 12966

OSVDB: 15233, 15234, 16602