TrackerCam Multiple Remote Overflows

High Nessus Network Monitor Plugin ID 2632

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host is running TrackerCam. TrackerCam is a web server that allows remote users to view real-time video streams from an attached camera. This version of TrackerCam is vulnerable to multiple remote buffer overflows. An attacker exploiting one of these flaws would connect to the web server and send a large malformed request. Successful exploitation would result in the attacker being able to run arbitrary commands on the web server.

Solution

Upgrade to a version of TrackerCam higher than 5.12.

Plugin Details

Severity: High

ID: 2632

Family: Web Servers

Published: 2005/02/21

Modified: 2016/01/21

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:U/RC:X

Exploitable With

Metasploit (TrackerCam PHP Argument Buffer Overflow)

Reference Information

CVE: CVE-2005-0478, CVE-2005-0479, CVE-2005-0480, CVE-2005-0481, CVE-2005-0482

BID: 12592