Apache mod_python < 3.1.4 Information Disclosure

Medium Nessus Network Monitor Plugin ID 2608

Synopsis

The remote host may give an attacker information useful for future attacks.

Description

The remote Apache server is running a version of mod_python that is older than 3.1.4. This version contains a flaw wherein specially formatted requests can cause mod_python to divulge information regarding paths, file locations, and more. An attacker can use this flaw in order to gain more information about the machine.

Solution

Upgrade to mod_python 3.1.4 or higher.

Plugin Details

Severity: Medium

ID: 2608

Family: Web Servers

Published: 2005/02/10

Modified: 2018/07/11

Dependencies: 3057

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:mod_python

Reference Information

CVE: CVE-2005-0088

BID: 12519