PostgreSQL < 8.0.1 Multiple Remote Vulnerabilities

Medium Nessus Network Monitor Plugin ID 2583

Synopsis

The remote host is missing a critical security patch or upgrade.

Description

The remote PostgreSQL server is vulnerable to a number of critical flaws. Some of these flaws require an attacker to have a valid account with credentials; however, some of the attacks do not require the attacker to have any sort of credentials.

Solution

Upgrade to PostgreSQL 8.0.1 or higher.

Plugin Details

Severity: Medium

ID: 2583

File Name: 2583.prm

Family: Database

Published: 2005/02/01

Modified: 2016/02/05

Dependencies: 8704

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.6

Temporal Score: 4

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 5.9

Temporal Score: 5.6

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Reference Information

CVE: CVE-2005-0227, CVE-2005-0244, CVE-2005-0245, CVE-2005-0246, CVE-2005-0247

BID: 12411, 12417