ngIRCd < 0.8.2 Lists_MakeMask Function Remote Buffer Overflow

Critical Nessus Network Monitor Plugin ID 2574

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host is running a version of the ngIRCd service that may be vulnerable to a buffer overflow in the way the server handles list names. An attacker may execute code on the remote host by using a malicious user information.

Solution

Upgrade to ngIRCd 0.8.2 or higher.

See Also

http://bugs.gentoo.org/show_bug.cgi?id=79705

http://ngircd.barton.de/doc/ChangeLog

http://arthur.barton.de/pipermail/ngircd-ml/2005-January/000228.html

Plugin Details

Severity: Critical

ID: 2574

File Name: 2574.prm

Family: Generic

Published: 2005/01/29

Modified: 2016/01/19

Nessus ID: 16274

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Reference Information

CVE: CVE-2005-0199

BID: 12397

OSVDB: 13300