W-Agora Multiple Input Validation Vulnerabilities

High Nessus Network Monitor Plugin ID 2339

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host is running W-Agora, a web-based forum management software written in PHP.
There are multiple input validation flaws in the remote version of this software :

- There is an SQL injection vulnerability in the file 'redir_url.php' that may allow an attacker to execute arbitrary SQL statements in the remote database ;
- There is a cross site scripting issue that may allow an attacker to steal the cookies of the legitimate users of the remote site by sending them a specially malformed link ;
- There is an HTTP response splitting vulnerability that may also allow an attacker to perform cross-site scripting attacks against the remote host.

Solution

Upgrade or patch according to vendor recommendations.

See Also

http://lists.grok.org.uk/pipermail/full-disclosure/2004-September/027040.html

Plugin Details

Severity: High

ID: 2339

Family: Web Servers

Published: 2004/10/01

Modified: 2016/01/21

Dependencies: 1442

Nessus ID: 15402

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:U/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7.3

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:U/RC:C

Reference Information

CVE: CVE-2004-1562, CVE-2004-1563, CVE-2004-1564, CVE-2004-1565

BID: 11283