Xine-lib < 1.0 RC6a Heap and Stack Overflows

Medium Nessus Network Monitor Plugin ID 2304

Synopsis

The remote host is vulnerable to multiple buffer overflows.

Description

The remote host is using a software linked again xine-lib, an open-source multimedia library. It is reported that versions up to 1.0 rc6a are vulnerable to multiple overflows in the DVD, subtitles and Video-CD modules. An attacker may craft a malicious multimedia file that may execute arbitrary code on the remote host if played with a xine-lib based software.

Solution

Upgrade to Xine-lib 1.0 RC6a or higher.

Plugin Details

Severity: Medium

ID: 2304

File Name: 2304.prm

Family: Web Clients

Published: 2004/09/21

Modified: 2016/01/21

Dependencies: 1735, 8314

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.1

Temporal Score: 5

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Reference Information

CVE: CVE-2004-1379, CVE-2004-1475, CVE-2004-1476

BID: 11205, 11206