myServer < 0.7.1 Directory Traversal Arbitrary File Access

Medium Nessus Network Monitor Plugin ID 2293

Synopsis

The remote host is vulnerable to a flaw that allows attackers to retrieve sensitive files or data.

Description

The remote host is running myServer 0.7.0 or older. There is a flaw in the remote version of this software that may allow an attacker to read arbitrary files on the remote host with the privileges of the web server process using malformed URI.

Solution

Upgrade to version 0.7.1 or higher.

Plugin Details

Severity: Medium

ID: 2293

File Name: 2293.prm

Family: Web Servers

Published: 2004/09/15

Modified: 2016/01/21

Dependencies: 1723

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Reference Information

CVE: CVE-2004-2516

BID: 11189

OSVDB: 10001