Mozilla Firefox < 1.7.3 Multiple Vulnerabilities

Low Nessus Network Monitor Plugin ID 2287

Synopsis

The remote host has a web browser installed that is vulnerable to multiple attack vectors.

Description

Versions of Mozilla Firefox prior to 1.7.3 are prone to multiple vulnerabilities including overflows and cross-site scripting issues. An attacker may execute arbitrary code remotely, steal cookie-based authentication credentials or gather intelligence about the host.

Solution

Upgrade to Firefox 1.7.3 or later.

See Also

http://www.mozilla.org/security

Plugin Details

Severity: Low

ID: 2287

File Name: 2287.prm

Family: Web Clients

Published: 2004/09/15

Modified: 2016/03/12

Dependencies: 9131

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 2.6

Temporal Score: 2.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 3.6

Temporal Score: 3.3

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Reference Information

CVE: CVE-2004-0904, CVE-2004-0903, CVE-2004-0905, CVE-2004-0908

BID: 11179, 11177, 11174, 11171, 11170, 11169