Abyss < 1.1.6 httpd GET Request Remote Overflow

High Nessus Network Monitor Plugin ID 2172

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote Abyss Web server is vulnerable to a buffer overflow that may be exploited by an attacker to execute arbitrary code on this host.

Solution

Upgrade to Abyss 1.1.6 or higher.

Plugin Details

Severity: High

ID: 2172

File Name: 2172.prm

Family: Web Servers

Published: 2004/08/30

Modified: 2016/01/21

Dependencies: 1442

Nessus ID: 11784

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:U/RC:C

Exploitable With

CANVAS (CANVAS)

Reference Information

CVE: CVE-2003-1337

BID: 8062, 8064