thttpd < 2.21 Error Page XSS

Medium Nessus Network Monitor Plugin ID 2123

Synopsis

The remote host is vulnerable to a Cross-Site Scripting (XSS) attack.

Description

The remote host is running a vulnerable version of Acme thttpd. It is reported that this version of thttpd fails to check URLs for the presence of script commands when generating error pages. An attacker may craft links containing scripting code in order to execute code within the context of the website.

Solution

Upgrade to thttpd 2.21 or higher.

Plugin Details

Severity: Medium

ID: 2123

Family: Web Servers

Published: 2004/08/18

Modified: 2016/02/05

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 3.6

Temporal Score: 3.3

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:acme:thttpd

Reference Information

CVE: CVE-2002-0733

BID: 4601