OpenSSH < 3.0.1 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 1986


The remote host is vulnerable to a flaw that allows for the bypassing of authentication.


The remote host is running a version of OpenSSH that is older than 3.0.1. Versions older than 3.0.1 are vulnerable to a flaw in which an attacker may authenticate, provided that Kerberos V support has been enabled (which is not the case by default). It is also vulnerable to an excessive memory clearing bug, believed to be unexploitable.

Note: PVS has solely relied on the banner of the SSH client to perform this check. Any backported patches or workarounds such as recompiling or edited configurations are not observable through the banner.

*** You may ignore this warning if this host is not using Kerberos V


Upgrade to OpenSSH 3.0.1 or higher.

See Also

Plugin Details

Severity: High

ID: 1986

File Name: 1986.prm

Family: SSH

Published: 2004/08/20

Modified: 2016/11/23

Dependencies: 1997, 3059

Nessus ID: 10802

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 8.4

Temporal Score: 7.8


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Exploitable With

Core Impact

Reference Information

CVE: CVE-2002-0575, CVE-2001-1507, CVE-2002-0083

BID: 3560, 4560, 4241