PostgreSQL < 7.2.3 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 1892

Synopsis

The remote host is vulnerable to a flaw which allows for the bypassing of authentication.

Description

The remote PostgreSQL server is vulnerable to various flaws which may allow an attacker who has the right to query the remote database to obtain a shell on this host.

Solution

Upgrade to PostgreSQL 7.2.3 or higher.

Plugin Details

Severity: Medium

ID: 1892

File Name: 1892.prm

Family: Database

Published: 2004/08/20

Modified: 2016/01/21

Dependencies: 8703

Nessus ID: 11456

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 5.5

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Reference Information

CVE: CVE-2002-0972, CVE-2002-1398, CVE-2002-1402, CVE-2002-1401, CVE-2002-1400, CVE-2002-1397, CVE-2002-1399

BID: 6610, 6614, 5527, 5497, 6615, 6611, 6612, 6613, 7075