qpopper < 4.0 PASS Command Remote Overflow

High Nessus Network Monitor Plugin ID 1785

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

There is a vulnerability in some versions of qpopper which allows a remote user to become root using a buffer overflow.

Solution

Upgrade to version 4.0 or higher.

Plugin Details

Severity: High

ID: 1785

Family: POP Server

Published: 2004/08/20

Updated: 2019/03/06

Dependencies: 3035

Nessus ID: 10196

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 8.3

Temporal Score: 6.9

Vector: CVSS2#AV:A/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 8.7

Temporal Score: 8

Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:qualcomm:qpopper

Reference Information

CVE: CVE-1999-0006

BID: 133