Neon < 0.24.7 WebDAV Client Library Unspecified Vulnerability

High Nessus Network Monitor Plugin ID 1781

Synopsis

The remote host is missing a critical security patch or upgrade.

Description

The remote host is using software based on a vulnerable version of the Neon Library, an open-source HTTP and WebDAV client library. It is reported that versions prior 0.24.7 contains an unspecified vulnerability. Due to the nature of the library, it is likely that this is a remotely exploitable vulnerability.

Solution

Upgrade to Neon library 0.24.7 or higher.

Plugin Details

Severity: High

ID: 1781

File Name: 1781.prm

Family: Web Clients

Published: 2004/08/20

Modified: 2016/11/23

Dependencies: 1735, 8314

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:U/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 6.7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:U/RC:X

Reference Information

BID: 10869