Wget < 1.8.3 Rogue FTP Site File Deletion

Medium Nessus Network Monitor Plugin ID 1744

Synopsis

The remote host is using a version of wget that contains a bug that may allow a rogue FTP site being mirrored to delete arbitrary files on this host.

Description

The remote host is using a version of wget that contains a bug that may allow a rogue FTP site being mirrored to delete arbitrary files on this host.

Solution

Upgrade to version 1.8.3 or higher.

Plugin Details

Severity: Medium

ID: 1744

Family: Web Clients

Published: 2004/08/20

Modified: 2016/01/21

Dependencies: 1735, 8314

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gnu:wget

Reference Information

CVE: CVE-2002-1344, CVE-2002-1565

BID: 6352