Powie PHP Forum < 1.15 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 1732

Synopsis

The remote web server contains a script which is vulnerable to a SQL injection attack.

Description

The remote host is running an old version of Powie PHP Forum, a web forum software implemented in PHP. It is reported that version prior 1.15 are vulnerable to multiple security issue including cross-site scripting and SQL injection. An attacker may gain access on the forum as a specific user or as an administrator or steal a victim's cookie-based authentication credentials using malicious HTML code.

Solution

Upgrade to Powie PHP Forum 1.15 or higher.

Plugin Details

Severity: High

ID: 1732

Family: Web Servers

Published: 2004/08/20

Modified: 2018/07/11

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:powie:pforum

Reference Information

CVE: CVE-2002-0287, CVE-2002-0319

BID: 4165, 4114