AutomatedShops webc.cgi Multiple Overflows

High Nessus Network Monitor Plugin ID 1572

Synopsis

The remote host is running webc.cgi, a shopping cart application, which is older than 5.020.

Description

The remote host is running webc.cgi, a shopping cart application, which is older than 5.020. This CGI is vulnerable to a remote buffer overflow as well as a local one. An attacker may exploit this flaw to execute arbitrary code on this host.

Solution

Upgrade to version 5.020 or higher.

Plugin Details

Severity: High

ID: 1572

Family: Web Servers

Published: 2004/08/20

Modified: 2018/09/16

Dependencies: 1442

Nessus ID: 11515, 11516

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:X

Reference Information

BID: 7268, 7277