Monkey HTTP Daemon < 0.6.2 PostMethod Function Remote Overflow

High Nessus Network Monitor Plugin ID 1561

Synopsis

It is possible to make the remote web server crash when sending a POST command with too much data in it.

Description

It is possible to make the remote web server crash when sending a POST command with too much data in it. An attacker might also exploit this flaw to execute arbitrary code on this host.

Solution

Upgrade to version 0.6.2 or higher.

Plugin Details

Severity: High

ID: 1561

Family: Web Servers

Published: 2004/08/18

Modified: 2018/09/16

Dependencies: 1442

Nessus ID: 11544

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.6

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:monkey-project:monkey_http_daemon

Reference Information

CVE: CVE-2003-0218

BID: 7202