mod_ssl < 2.8.10 Wildcard DNS Server Name XSS

Medium Nessus Network Monitor Plugin ID 1529

Synopsis

The remote host is using a version of mod_ssl which is older than 2.8.10.

Description

The remote host is using a version of mod_ssl which is older than 2.8.10. This version is vulnerable to a flaw which may allow an attacker to successfully perform a cross-site scripting attack. *** Note that several Linux distributions (such as RedHat) patched this CGI without increasing its version number, therefore this might be a false positive.

Solution

Upgrade to mod_ssl 2.8.10 or higher.

See Also

http://archives.neohapsis.com/archives/bugtraq/2002-10/0374.html

Plugin Details

Severity: Medium

ID: 1529

File Name: 1529.prm

Family: Web Servers

Published: 2004/08/18

Modified: 2016/11/23

Dependencies: 3057

Nessus ID: 11622

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Reference Information

CVE: CVE-2002-1157

BID: 6029